ExecJS::RuntimeUnavailable

Quando você iniciar uma nova aplicação no Rails 3.1 é capaz que apareça este erro:

/gems/execjs-1.2.4/lib/execjs/runtimes.rb:45:in `autodetect': Could not find a JavaScript runtime. See 
https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable)

A solução:

sudo apt-get install nodejs

 

 

3 comentários

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s